Difficulties with FDS ELEC panel for 737NG

Dedicated to The Support of All Flightdeck Solutions, Ltd Products

Moderators: Curtis, Jetcos

Post Reply
stephenbalmer
Posts: 4
Joined: Fri May 17, 2019 2:54 pm

Difficulties with FDS ELEC panel for 737NG

Post by stephenbalmer »

I purchased the ELEC panel for the overhead of my 737ng build a while ago. It did work at the time of receiving and testing, however that was testing practically the individual component. Now that I am getting back to my build, when trying to include the ELEC panel in the myriad of other components, I am finding performance very erratic.

It is working ok, not defective – when I strip off all the other USB components and hook up through my Prosim737 V2, all is great.

However when I then add all the other USB components, it works until I perform a reboot and then after reboot, the ELEC panel refuses to power up until I strip off all the other USB connections, reboot Prosim737 again and then it is happy.

I have tried connecting it through the USB on the back of my PC and on various powered USB hubs and always the behaviour is as above. It is like it doesn’t like coming online when it is not alone, but when I bring it online as a lone connection and then add the other USB components, it does stay up… very strange.

Any ideas and are there any manuals for this component in case i am missing something? Thanks!

Jetcos
Posts: 1276
Joined: Fri Sep 30, 2005 2:42 pm
Location: Newmarket,Ontario
Contact:

Post by Jetcos »

Hi Stephen,

There is a manual but it only covers the assignments and pin-outs for the module. Not much is required.

Try running the ProSim "Hardware Connector" on another PC and plug the ELEC USB in that PC?

If you are connecting numerous USB devices into the P3D computer you may have reached your limit. Also make sure that you have the Power Management settings unchecked in the Device Manager/USB's.
Steve Cos
Vice President and Tech Support
Flightdeck Solutions (FDS)

stephenbalmer
Posts: 4
Joined: Fri May 17, 2019 2:54 pm

Post by stephenbalmer »

Thanks Steve, I shall try the USB hub power management settings as well to resolve this.

In addition, could you possibly send me any design information on the measurements of the ELEC panel - i need to 3d print the mask for the overhead display unit and thought if you had the measurements of the digital display positions, it would be better than measuring?

Thanks, Steve.

GDR
Posts: 339
Joined: Fri Sep 26, 2008 3:16 am
Location: EBBR
Contact:

Post by GDR »

Hi Stephen,

Also a good thing is to clear unused devices from the device manager. Unplugging an plugging in again on another usb port adds the device again, as new device. Windows has a limit of 127 normally. So they say . :wink:

I ran in some similar situation. Cleaning up resolved it for me.
It are the ones with a grey icon.
Check below link....

https://www.thewindowsclub.com/show-non ... es-windows
Geert.

Full B737-MAX DSTD - ALL FDS
Sim-Avionics V1.965
P3D v5
FSUIPC v6

What goes up, must eventually come down!
http://www.flightsim737.be
http://www.flightsim737max.be
http://www.flightsim737ng.be

Post Reply