Flightdeck Solutions Forum Index Flightdeck Solutions
The place to meet and talk with fellow builders
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Undercarriage retracts automatically.
Goto page Previous  1, 2
 
Post new topic   Reply to topic    Flightdeck Solutions Forum Index -> Open Discussion
View previous topic :: View next topic  
Author Message
Winstonc



Joined: 09 Mar 2016
Posts: 307
Location: California

PostPosted: Sun Dec 24, 2017 8:50 pm    Post subject: Reply with quote

Just loaded sim-a 1.8 and 1.8 737 model and again the undercarriage is behaving correctly and not auto-retracting.

David
Back to top
View user's profile Send private message
MichaelYSSY



Joined: 06 Jan 2015
Posts: 493
Location: Sydney - Australia

PostPosted: Tue Dec 26, 2017 4:38 am    Post subject: Reply with quote

Hi

Well I followed David's lead and loaded SA 737Aircraft 1.8 and Sim Avionics 1.8

The first flight the gear behaved its self the second time I used the sim it's back to gear retracting on its own straight after positive rate.
I checked from an external view and can confirm that the gear retracts in FS and plays FS gear retract sound only.
When I move gear lever up up position the Sim Avionics sound plays.

I then restarted the rig with FS only and no Sim Avionics connected and after takeoff and positive rate I can confirm that the gear does NOT retract by its self.

Anyone have any ideas?

Cheers
Michael
_________________
SSTD 737, SA 737 v1.83
P3D 4.1 FSUIPC 5.122
Back to top
View user's profile Send private message
MarkHastings



Joined: 18 Jan 2006
Posts: 735
Location: UK

PostPosted: Wed Dec 27, 2017 2:24 pm    Post subject: Reply with quote

Do you load a 'Scenario' before flying ?
The Gear lever state may be getting loaded from the scenario.
In this case try selecting the checkbox on the Control Panel "Do Not load system with Scenarios"

Second, How is your gear lever assigned ?
On the Sys controller there are 3 options Gear UP, Gear OFF, Gear Down.
FDS Gear levers usually have an UP and a DOWN microswitch, so you should have a switch event assigned to Gear UP and a switch event assigned to Gear DOWN.
Nothing on "Assign 2"
No OFF Events.

Lastly, On v1.80 I added a log file that may help me to diagnose certain situations.
Please can you start and fully load your sim ready for flight.
Then goto the Server menu > System > Create Support Debug Files
This will create 9 files in a folder in "\Server" called "\SUPPORT_INFO".
Please zip up these files and mail them to me.

FYI: If you open "Server_Debug_Data_New.log" a few lines down you'll see the current Commanded Gear Position.

Also...
You can monitor the FS gear offset using the Server FSUIPC Monitor.
This is how the lever is currently set in FS.
The offset is 0BE8
Type = 4 Unsigned
(0 = UP, 1 = DN)
_________________
Mark Hastings
Software Developer
Sim-Avionics
Back to top
View user's profile Send private message Visit poster's website
Winstonc



Joined: 09 Mar 2016
Posts: 307
Location: California

PostPosted: Wed Dec 27, 2017 2:44 pm    Post subject: Reply with quote

Hi Mark

I already have "Do not load system with Scenarios" checked.

I have the up input and down inputs assigned to the On inputs,
I do however have the up and down inputs off events assigned to Gear Off, so I guess that may be the issue although I am not sure why as the gear lever is in the down position when I take off and yet I still get an UN-commanded retract. I will clear everything for the Gear Off position and see if that fixes the problem.

I will check again and create a log file.

Thanks

David
Back to top
View user's profile Send private message
hillryanc



Joined: 08 Dec 2016
Posts: 42

PostPosted: Sat Feb 03, 2018 4:07 pm    Post subject: Reply with quote

I'm not sure if this is the "solution", but I've found that only by starting from cold & dark do I not get the gear problem. I also don't get the gear problem after the first takeoff (cycling of gear) if not starting from cold & dark. Something is clearly bugged with the "initial state" scenario (or appears to be).
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    Flightdeck Solutions Forum Index -> Open Discussion All times are GMT - 5 Hours
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group