FDSTQ not seen by SysBoard Interface ( Resolved )

Dedicated to The Support of All Flightdeck Solutions, Ltd Products

Moderators: Curtis, Jetcos

Post Reply
Posts: 83
Joined: Tue Jan 05, 2010 9:57 am

FDSTQ not seen by SysBoard Interface ( Resolved )

Post by fox956 »


I'm having a problem with the FDS TQ not being detected by the SysBoard Interface.

I've changed the Ethernet cable running from the TQ into the Ethernet Switch, I've even plugged the TQ Ethernet cable from the TQ directly into the Sim A computer and the TQ is still not seen by the SysBoard Interface. In the box at the top of the SysBoard Interface where it tells what board is being loaded, I see it says the FDSTQ.dll is loaded.

Is there anything I can check to narrow down the problem I'm having?

Last edited by fox956 on Thu Jun 11, 2020 5:25 am, edited 1 time in total.

Posts: 68
Joined: Wed Feb 20, 2013 10:33 pm
Location: Newmarket, Ontario, Canada

Re: FDSTQ not seen by SysBoard Interface

Post by VE3ORE »

Which version of the TQ is this? Powered or static (i,e, Jetmax) ?

Has it worked before?


Posts: 339
Joined: Fri Sep 26, 2008 3:16 am
Location: EBBR

Re: FDSTQ not seen by SysBoard Interface

Post by GDR »

Hi Larry,

Check in C:\Sim-Avionics\Documentation for the Throttle setup document (or via SIm-A Server, Documentation).

PS there is no use of connecting the TQ directly to the PC. The TQ needs an IP address. Connecting devices to a PC directly do need a cross cable instead of a normal network cable and then no IP address is assigned.

In Brief:
  • Connect the TQ to a network switch
  • Make sure that you have DHCP active on the network
  • Install the correct version of Phidgets SBC (see documentation // as per documentation: C:\Sim-Avionics\SYSBoard Interface\Plugins\Phidget22-x64_1.4.20190605.exe)
  • in SYSBoard, check the enable plugins
  • Next on the bottom left, checkt the FDS TQ module
Hope this helps you further.

Sim-Avionics V1.965
P3D v4.5.13.32097
FSUIPC v5.154

What goes up, must eventually come down!

Posts: 83
Joined: Tue Jan 05, 2010 9:57 am

Re: FDSTQ not seen by SysBoard Interface

Post by fox956 »

Hi Andy,

Yes, it worked fine a few days ago. I was having some problems with my network. I then decided to do a Win 10 update and since then it's a no-go. I have the FDSTQ powered version for the 737NG.

I've gone through the setup in the documentation and there seems to be a problem when it comes to the list of connected components as seen in the Phidgets Network Server Control Panel as in the manual, my Control panel isn't showing any connected phidget devices. I don't know if this is a problem with the software installation or a problem with the TQ itself. In the documentation it mentions about starting the Phidgets Control program and a message would appear when selecting the Network Phidgets Tab about installing Bonjour. When I originally installed the TQ I remember getting this message, now I don't get this message, not sure if Bonjour is already installed or not.

I'm hoping to hear back from Steve as where to proceed from here.


Posts: 748
Joined: Tue Jan 06, 2015 11:04 pm
Location: Sydney - Australia

Re: FDSTQ not seen by SysBoard Interface

Post by MichaelYSSY »

Windows 10 and Updates
You really do not know what to expect from updates but one thing for sure Win 10 (after you update) will restore default security settings, tighten up the Firewall settings and delete all your share settings.
Another thing it will reset is your Network settings causing your pc to gain a new IP address which is required for connection of Sim A and other related programs.
It is difficult enough the get your FS settings back and then you have to try to remember all the network and share stuff as well.

Good Luck

Oh, and any firewall ports that you have opened will be closed too.
SSTD 737
Sim-Avionics v1.96
P3D 4.5/5.0 HF1
FSUIPC 6.0.8

Posts: 83
Joined: Tue Jan 05, 2010 9:57 am

Re: FDSTQ not seen by SysBoard Interface

Post by fox956 »

The problem I was having was a Network issue. The TQ had an IP address that wasn't being recognized by the Network. Thanks to Steve he was able to fix the problem.

This problem started first with a Win 10 update, and at the same time I was having a problem with the Sim A computer not booting up properly, it would stop at the BIOS screen upon start up everytime. That issue turned out to be a bad battery on the motherboard.

I have to admit that this Network stuff is not my strong suite, far from it.

Thanks to all for your comments. This can be marked as resolved.


Post Reply